activiti-engine OSGi bundle requires junit classes

Description

The MANIFEST.MF file in activiti-engine.jar states:


Although the org.junit (root) package has resolution optional, the sub packages lack this addition and are thus required. To install the bundle, the junit classes need to be loaded into the OSGi container.

This makes the bundle unusable in an OSGi production environment.

Environment

apache karaf 3.0.0

Assignee

Joram Barrez

Reporter

Maarten Winkels

Labels

None

Components

Fix versions

Affects versions

Priority

Major
Configure